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CHAPTER 1

Fundamentals of Computer

Data and Information

Data denotes raw facts and figures such as numbers, words, etc. that can be processed or 
manipulated.

Eg:- Suresh, 17, 12

Information is the meaningful and processed form of data.

Eg:- 

Comparison between Data & Information

Data Information

Raw facts and figures Processed data

Similar to raw material Similar to the finished product

Cannot be directly used Helps in taking decisions

Not precise and clear Clear and Meaningful

Data processing

Data processing refers to the operations or activities performed on data to generate information.

Different stages in data processing

1. Capturing data

2. Input 

3. Storage

4. Processing/Manipulating data

 5. Output

6. Distribution of information

Functional units of a computer

Input Unit, Central Processing Unit(CPU), Storage Unit and Output Unit.
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1. Input Unit

Accepts instructions and data for processing.

Eg:- Keyboard, mouse

2. Central Processing Unit (CPU)

The CPU is the brain of the computer. All major computations and comparisons are made 
inside the CPU. 

The functions of CPU are performed by three components:- 

(i) Arithmetic Logic Unit(ALU): It performs all arithmetic and logical operations.

(ii) Control Unit(CU): It manages and co-ordinates all other units of the computer.

(iii) Registers: These are the temporary storage areas inside the CPU.

3. Storage Unit

Store data and instructions, intermediate results and final results.

4. Output Unit

Supplies the results to the outside world.

Eg:- Monitor, Printer

Computer:

It is an electronic device for storing and processing data according to instructions given to it.

Characteristics of Computers

Advantages: Speed, Accuracy, Diligence, Versatility, Huge memory

Limitations: Lack of IQ, Lack of decision making power

Number system
The number of symbols used in a number system is called base or radix.

Number System Base Symbols used Example

Binary 2 0, 1 (1101)2

Octal 8 0, 1, 2, 3, 4, 5, 6, 7 (236)8

Decimal 10 0, 1, 2, 3, 4, 5, 6, 7, 8, 9 (5876)10

Hexadecimal 16 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, F
(A, B, C, D, E, F represents 10, 11, 12, 13, 14, 15 respectively)

(12AF)16

Representation of numbers

There are three methods for representing an integer number in computer memory. 

• (i) Sign and magnitude representation

• (ii) 1’s complement representation

• (iii) 2’s complement representation
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Representation of characters

Different methods to represent characters in computer memory are:

• ASCII (American Standard Code for Information Interchange).

• EBCDIC (Extended Binary Coded Decimal Interchange Code).

• ISCII (Indian Standard Code for Information Interchange).

• Unicode.

Sample Questions
1. Meaningful and processed form of data is known as ..............

2. The number of symbols used in a number system is called ...............

3. ASCII stands for .................

4. The base of hexadecimal number system is ..............

5. CPU stands for .................

6. Distinguish between data and information.

7. List down the characteristics of computers.

8. Name the components of CPU.

9. What are the methods of representing integers in computer memory?

10. With the help of a block diagram, explain the functional units of a computer.
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CHAPTER 2

Components of the Computer System

Memory

Memory is a place where we can store data, instructions and results temporarily or permanently. 

Memory measuring units

Primary memory

Primary memory is a semiconductor memory that is accessed directly by the CPU. 

Three types of primary memory are RAM, ROM and Cache.

Comparison between RAM and ROM

RAM (Random Access Memory) ROM (Read Only Memory)

It is volatile, i.e. it will lose its data 
if the power is turned off.

It is non-volatile, i.e. it keeps its data 
even if the power is turned off.

It is faster than ROM It is a slower memory

It allows reading and writing. Allows reading only.

It stores programs that are currently 
running.

It stores the program required to boot 
the computer.

Input devices

An input device is used to feed data and instructions into the computer.

Different types of input devices are:

1. Keyboard: It is an input device used to input alphabets, numbers and other characters.

2. Mouse: It is a hand-held device that controls the movement of the cursor on a display screen.

3. Light pen: It is a light-sensitive pointing device used to draw pictures on a computer screen.

4. Touch screen: It allows the user to operate the computer by simply touching on the display 
screen.

5. Graphic tablet: It allows artists to create graphical images.

6. Touchpad: It is a pointing device used to move the mouse pointer on a display screen.

7. Joystick: It is a pointing device commonly used for playing video games.

8. Microphone: It is used to input sound.

9. Scanner: It is an input device that scans documents such as photos and pages of text.

10. Optical Mark Reader (OMR): It reads pencil marks made on pre-defined positions on the 
OMR form. It is used to process competitive exam results quickly and accurately..
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            11. Barcode Reader/Quick Response (QR) code reader

Barcode readers are electronic devices for reading printed barcodes.

A QR code is similar to barcodes. Barcodes are single dimensional whereas QR codes are 
two dimensional. It can store website URLs, plain text, phone numbers, etc.

12. Magnetic Ink Character Recognition (MICR) Reader: It is used in banks for faster clearing 
of cheques.

13. Biometric sensor: It is used to identify unique human physical features like fingerprints, 
retina, etc.

14. Smart card reader: A smart card is a plastic card that stores and transacts data (Eg:- ATM 
Card). Smart card readers are used to access data in a smart card.

15. Digital camera: It can take pictures and videos and that can be transferred to a computer.

Output devices

Output device is used to present information from a computer system.

Different types of output devices are:

1. Monitor

An output device used to display information from a computer.

Different types of Monitors are:

a. Cathode Ray Tube (CRT) monitor: Similar to old television sets. Use more power, produce
lot of heat.

b. Flat panel monitor: It is thinner, lighter in weight, consume less power, emit less heat.

Eg:- LCD Monitors, LED Monitors, Plasma Monitors, OLED Monitors.

2. LCD projector

It is used for displaying video, images or computer data on a large screen.

3. Printer

Printers are used to produce hardcopy output.

Classified into two:- impact and non-impact printers.

Impact printers direct contact with the paper while printing. Eg:- Dot-matrix printers.

Dot Matrix Printer (DMP)

• Printing material: Ink ribbon

• Cheaper to print, Carbon copy possible, slow, noisy.

Non-impact printers do not touch the paper while printing.

Eg:- Inkjet, Laser and Thermal printers

Inkjet printer

• Printing material: Liquid ink

• Quiet, high print quality, printers are inexpensive, ink is expensive.

Laser printer

• Printing material: Ink powder

• Quiet, prints faster, high print quality, Toner is expensive, Device is expensive.
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Thermal printer

• Printing material: Heat sensitive paper.

• Quiet, faster, smaller, lighter, consume less power, portable.

4. Plotter

It is an output device used to produce hard copies of large graphs and designs on the paper.

It is used in the design of cars, ships, aircrafts, buildings, highways etc.

5. Three dimensional (3D) printer

It is a new generation output device used to print 3D objects.

It can print ceramic cups, plastic toys, metal machine parts, etc.

6. Speakers

Speakers are the output device that produces sound.

e-Waste

e-Waste refers to electronic products nearing the end of their "useful life".

Eg:- discarded computers, mobile phones, television sets, refrigerators.

e-Waste disposal methods

a. Reuse: It refers to second-hand use.

b. Incineration: It is a combustion process in which the waste is burned at a high temperature.

c. Recycling: It is the process of making new products from old devices.

d. Land filling: In this method soil is excavated and e-waste is buried in it.

System software

It is a set of one or more programs designed to control the operations of a computer.

Components of system software are: 

Operating system, Language processors and Utility software.

a. Operating system

It is a set of programs that acts as an interface between the user and computer hardware. 

Example:- DOS, Windows, Unix, Linux

Major functions of an Operating System are: 

Process management, Memory management, File management and Device management
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Low Level Language: machine-oriented languages. Two types:

a. Machine language: The language, which uses only binary digits 0 and 1.

b. Assembly language: is an intermediate-level symbolic programming language. 
It uses mnemonic symbols like ADD, SUB, etc.

High Level Language is like English language and is simpler to understand. Not

understandable to the computer.   Example: C++



b. Language processor

It translates programs written in high level language or assembly language into its equivalent 
machine language.

Types of language processors

Assembler: It converts assembly language into machine language.

Interpreter: It converts a high level language program into machine language line by line.

Compiler: It converts the whole high level language program into machine language at a time.

Free and open source software

It gives the user the freedom to use, copy, distribute, examine, change and improve the software.

Eg:- GNU/Linux, GIMP, Mozilla Firefox, OpenOffice.org

Four Freedoms of Free Software

Freedom 0 - The freedom to run program for any purpose.

Freedom 1 - The freedom to study how the program works and adapt it to your needs.

Freedom 2 - The freedom to distribute copies of the software.

Freedom 3 - The freedom to improve the program and release your improvements to the public.

Sample Questions
1. 1 Byte = ............ bits

2. Name the software that translates assembly language program into machine language program.

3. RAM stands for .................

4. OMR stands for .................

5. Give two examples for free and open source software.

6. Compare RAM and ROM.

7. What is an input device? List and explain any two input devices.

8. What is an output device? List few commonly used output devices.

9. Compare dot matrix printers and laser printers.

10. Give two examples for non-impact printers. 

11. Define  (a) Plotter  (b) 3D Printer

12. What is e-Waste? List and explain different e-waste disposal methods.

13. Define  (a) Assembler   (b) Interpreter   (c) Compiler

14. Define operating system. Give two examples for OS.

15. List four major functions of operating system.

16. What do you mean by free and open source software? Give two examples.

17. What are the four freedoms which make up free and open source software?
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CHAPTER 3

Data Processing with Electronic Spreadsheet

Spreadsheet Software

The software package for processing numbers and characters in tabular form.

Eg: Lotus1-2-3, Quattro Pro, Microsoft Excel, Open Office Calc

Features of an electronic spreadsheet

• stores large volume of data in tabular form like marklists

• carries out numeric calculations, comparisons and analysis using formulae and functions.

• automatically updates results, if any change is made in the related data.

• provides text formatting features 

• offers facilities like sorting, filtering, etc.

• creates charts for graphical data analysis.

Worksheet

A spreadsheet can contain one or more worksheets. By default, there will be three worksheets in a 
spreadsheet named Sheet1, Sheet2 and Sheet3.

Rows and columns

A worksheet is organised in rows and columns. The column header displays the column names A , 
B , C , .. , Z , AA , AB ,.....,etc. and row header displays the numbers 1 , 2 , 3 , . . . , etc.

Cell

Cell is the intersection of a column and a row. It is the smallest unit of the worksheet. Each cell has 
a unique address (Eg: A5).
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Range

A group of adjacent cells that form a rectangular area. The smallest range is a single cell and the 
largest range is the entire worksheet. It is specified by the addresses of the first cell in the range and
the last cell in the range. 

Eg: B3: E10

Components of a spreadsheet window

• Menu bar - Contains pull down menu options like File , Edit , View , Insert , Format ,Tools , Data , 
Window and Help . Each contains various options to perform operations on spreadsheet.

• Toolbars (Standard & Formatting) - Contain icons or short-cut buttons for commonly used menu 
commands. 

• Formula bar - Consists of Name Box , Function Wizard , Sum Button , Function Button and Input 
line.

• Sheet Tab - Shows the worksheets available in the spreadsheet.

• Status bar -An area where the current status about the worksheet is displayed.
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Entering data in a cell

To enter data in a cell, place cell pointer in the desired cell, and then type the data. The following 
are the different types of data that can be entered in a cell:

a. Numbers – Eg: 35, 225.75, -50

b. Text – Eg: Mark1, Mark2

c. Date and Time – Eg: 12/01/2014, 10:00:00 AM

d. Formula – Eg:  = A1 + B1

Saving a spreadsheet

We can save a spreadsheet in 3 ways:

1. File ---> Save

2. Save button on the Standard toolbar

3. Ctrl+S (Keyboard shortcut)

The file is saved with the extension .ods.

Inserting cell

To insert a cell, use the Cells option from the Insert menu (Insert -> Cells).

Inserting row

Rows can be inserted using the Rows option of Insert menu (Insert ->Rows).

Inserting column

Columns can be inserted using the Columns option of Insert menu (Insert-> Columns).

Inserting a worksheet

Choose Insert-> Sheet or press (+) in Sheet Tab.

Deleting Cells/Row/Column

Step 1: Select the cell, row or column to be deleted. 

Step 2: Choose Delete Cells option from Edit menu ( Edit-> Delete Cells).

Deleting a worksheet

From the Edit menu, select Delete option from the Sheet sub menu (Edit-> Sheet ->Delete).

Freezing rows and columns in a worksheet

Freezing is the act of making a selected set of columns or rows immovable while scrolling the 
worksheet. 

To freeze rows/columns, 

Step 1: click on the row header/column header to be frozen. 

Step 2: Select Freeze option from Window menu (Window ->Freeze).
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Headers and footers

Headers are text appearing on the top of every page in a document. Footers are text appearing at the
bottom of each page. They can be given to a spreadsheet using the Headers & Footers option of the
Insert menu (Insert-> Headers & Footers).

Printing a spreadsheet

A spreadsheet can be printed in 3 ways:

• File->Print

• Ctrl+P (Keyboard shortcut)

• Print button on the Standard tool bar

Export as PDF

PDF (Portable Document Format) files can be viewed on any platform. It is not easily editable. A 
worksheet can be exported to the PDF format using the menu option File ->Export as PDF.

Sample Questions

1. In a worksheet, ________ is formed when a row meets a column.

2. In a worksheet, D10: H25 is called a ________.

3. The short-cut buttons of important commands are present in ________.

4. The Save, Print commands are available in ______ menu of the worksheet window.

5. How do you insert a cell in a worksheet?

6. The act of making a column or row immovable is referred _______

7. Explain the main components of a worksheet window.

8. What do you mean by header and footer in a spreadsheet?

9. What is the advantage of exporting a worksheet to PDF format?
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CHAPTER 4

Data Analysis using Spreadsheet

Functions 

Functions are pre-defined formula in spreadsheets. 

They perform some specific operations and the result is displayed in the cell.

The built-in functions in spreadsheet are mainly categorised as Mathematical functions, Statistical 
functions, Logical functions and Text functions.

Mathematical functions.

Function Syntax Description

SUM ( )

SUM(Num1,Num2,Num3,....)
 Calculates the total of a set of 

numbers 

SUM(StartCell:EndCell).
 adds all numbers in the range of 

cells.

ROUND ( ) ROUND(Number, Count)

 Rounds the given number to a 
specified number of decimal places.

 Count is the number of decimal 
places to which the value is to be 
rounded.

ROUNDUP ( ) ROUNDUP(Number, Count)

 Rounds the given number up to a 
specified number of decimal places.

 Count is the number of decimal 
places to which the value is to be 
rounded.

ROUNDDOWN ( )
ROUNDDOWN(Number, 
Count)

 Rounds the given number down to
a specified number of decimal 
places. 

 Count is the number of decimal 
places to which the value is to be 
rounded.

COUNTIF() COUNTIF(Range, Criteria)
 Counts the number of values in the 

range that meets the specified 
criteria.
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Examples

SUM ( ) ROUND ( ) ROUNDUP ( ) ROUNDDOWN ( ) COUNTIF ( )

SUM(10,20,30) 
= 60

If Value in C3 = 
10,C4=20, 
C5=30,C6=40

Then SUM 
(C3:C6) = 100

ROUND(5.25,1) = 
5.3

ROUND(5.26,1) = 
5.3 

ROUND(5.257,2) 
= 5.26

ROUND(5.263,2) 
= 5.26

ROUNDUP(5.25,1) =
5.3

ROUNDUP(5.26,1) =
5.3 

ROUNDUP(5.257,2) 
= 5.26

ROUNDUP(5.263,2) 
= 5.27

ROUNDDOWN 
(5.25,1) = 5.2

ROUNDDOWN 
(5.26,1) = 5.2 

ROUNDDOWN 
(5.257,2) = 5.25

ROUNDDOWN 
(5.263,2) = 5.26

COUNTIF 
( K3:K12, 
“>=80” ) gives 
the number of 
students who 
have scored 80 
percent or 
more

Data manipulation

Sorting: Allows us to organise data in a specific order

Filtering: Find out records with a specific condition.

Charts: Charts are graphical representation of numeric data.

Chart elements

➢ Chart area: It includes the entire chart and all its element

➢ Chart title: The descriptive text for a chart.

➢ X-axis Title: The title given to the X-axis data range.

➢ Y-axis Title: The title given to the Y-axis data range

➢ X- axis Category: These are the categories of the data which have been plotted.

➢ Y axis value: This is the data range marked to plot the data series

➢ Data legends: A legend is a box that specifies the colour, symbol or pattern assigned to the data 
series.
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Chart types

There are mainly 4 different types of charts

 Column charts

 Bar charts

 Line Charts

 Pie Charts

Sample Questions

1. Name any four mathematical function used in spreadsheet

2. List any two charts in spread sheet software.

3. Explain the elements of chart and different types of charts used.
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CHAPTER 5

Presentation Software

Presentation Software

➢ Presentation software is used to demonstrate a concept or subject in front of others with the help of 
pictures, audio and video.

➢ Open Office Impress and Microsoft PowerPoint are the two popular software.

Presentation Software IDE

Creating a presentation 

When we open Impress, a dialogue box showing the Presentation Wizard. Then the Empty 
presentation option is selected by default and then the Create button at the bottom of the wizard is 
clicked

Components of presentation software

• Title Bar

• Menu Bar

• Tool Bars like Standard, Presentation, Drawing, etc.

• Tasks pane

• Slides pane

• Status Bar

Function Option Shortcut key

Saving a presentation File ->Save Ctrl + S

Opening a presentation File->Open Ctrl + O

Adding new slides Insert->Slide Enter Key
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Duplicating and deleting slides

Duplicate Right Click on slide -> Duplicate

Delete Right Click on slide -> delete

Inserting Objects

Table Insert -> Table

Sound file Insert-> Movie and Sound option -> select audio file ->open.

Video clip  Insert-> Movie and Sound option ->select video  file.

Hyperlinks Insert ->Hyperlinks

Views of the slides

➢ Normal view (Slide view)

➢ Outline view

➢ Notes view

➢ Handout view

➢ Slide Sorter view

                 Sample Questions

1. Name any two popular presentation software?

2. Give the names of different components of presentation software IDE?

3. Write the shortcut key to open a file?

4. How do you insert hyperlinks in a slide?

5. Discuss the different ways of inserting a sound file to a slide?

6. Mention different slide views in presentation?

7. How do you add new slides in presentation? 

8. What do you mean by Duplicating a slide?  Write the steps to duplicate a slide?
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CHAPTER 6

Getting Started with GIMP

Image editing Software

The software used for editing or manipulating of an image or a graphic. 

Uses of Image Editing software

• Resizing, cropping, colouring, combining and altering digital images

• Remove scratches, wrinkles, dirt and imperfections from images

• Sharpen or blur images

• Rotate or flip images

• Conversion from one image format to another

Classification of Image Editors

1. Raster graphics editors – Eg: GIMP, Photoshop, gThumb Image Viewer

2. Vector graphics editors – Eg: Adobe Illustrator, Corel DRAW, Inkscape

3. 3D Modelers – Eg: 3D Studio MAX, Animation Master, K-3D

Comparison between Raster and Vector images

Raster Vector

Raster image is made up of pixels.
Vector image is created mathematically using 
formulas.

Quality of raster images decreases as they are 
scaled.

Vector images can be scaled to any size 
without losing quality of image.

Raster images are capable of displaying any 
colour.

Vector images do not permit colour editing to 
the extent as possible with raster images.

Raster images are often large files. Vector images are relatively smaller in size.

Raster images are used in web and print.
Vector images are converted to raster images 
before they are used for web and printing.

GIMP(GNU Image Manipulation Program)

An application suitable used for tasks such as retouching of photographs, composing and authoring
images.

Features of GIMP

➢ Full suite of painting tools including brushes, pencil, airbrush, cloning, etc.

➢ Multiple undo/redo.
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➢ Selection tools including rectangle, ellipse, free, fuzzy etc.

➢ Transformation tools including rotate, scale, shear and flip.

➢ Supports multiple layer facility.

➢ Supports file formats like GIF, JPEG, PNG, TIFF, and BMP.

➢ Advanced scripting capabilities.

Canvas creation

To create a new canvas, click on New in File menu(File->New). Give a suitable canvas size and 
click OK.

Saving images

Select Save option from the File menu(File->Save). The project will be saved with the 
extension .xcf (Experimental Compact Facility).

Selection Tools

Selection tools are designed to select regions from the active layer so that we can work on them 
without affecting the unselected areas. These tools can be accessed using the menu, Tools-> 
Selection Tools or from the Toolbox. The different selection tools available in GIMP are: 

i. Rectangle Select

ii. Ellipse Select

iii. Free Select(Lasso Tool)

iv. Foreground Select

v. Fuzzy Select(Magic Wand)

vi. By Color Select

vii. Intelligent Scissors

Transform Tools

Transform tools change the size, position and angle of the image. These tools are available in the 
Toolbox or from Tools-> Transform Tools. The different transform tools available in GIMP are 
the following:

• Align

• Move

• Crop

• Rotate

• Scale

• Shear

• Flip
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Sample Questions

1. Classify the following software and give suitable headings.

      CorelDRAW, GIMP, Photoshop, Inkscape, 3D Studio MAX

2. Compare raster and vector graphics.

3. List the features of GIMP image editor.

4. Name any five selection tools available in GIMP.

5. List any three transform tools in GIMP.
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CHAPTER 7

Advanced Tools for Image Editing 

Use of path tool 

➢ Paths tool is used to create straight lined and smooth curved vector shapes and paths.

➢ This tool is very much useful to create different types of patterns.

➢ Path tool is also used to select a portion of an image in different shapes from an already existing     
picture.    

Comparison of subtractive and additive colour schemes

        

Filters

Filter is a very powerful tool used to modify and add various effects in an image. Filters can be 
applied to a complete layer or only to a selected region. The filters used in Gimp are:

1. Blur

2. Sharpen

3. Distorts

4. Light and shadow

5. Artistic

Blur filter

These filters blur images in a variety of ways. These filters are available in Filters->Blur

a. Gaussian Blur

b. Simple Blur
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c. Motion Blur               

d. Pixelize

e. Selective Gaussian Blur

Distorts Filter

These filters transform the image in different ways. They are available in the menu item  
Filters→Distorts

a. Emboss.

b. Mosaic

c. Ripple

d. Shift

e. Waves

f. Wind

Light and Shadow Filter 

These filters effectively use light and shadow to produce various effects in the image. They are 
available in the menu item Filters -> Light and Shadow

a. Lens Flare

b. Lightning Effects

c. Supernova

Artistic Filter

These filters are used to create artistic effects in the image. These filters are available in the menu 
item Filters -> Artistic.

 a. Clothify

b. Cubism

c. Oilify

d. Soft Glow

e. Weave
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Sample Questions

1. Which is the tool used to create straight lined or curved paths?

2. In the Additive colour method, the mixing of colours begins with ________ and ends with 
_______ colours.

3. In the subtractive colour method, the absence of all the colours is _______colour.

4. In the additive colour method, the absence of all the colours is ________colour.

5. ‘Cubism’ filter is available in _______ category of filters.

6. ‘Supernova’ filter is available in _______ category of filters.

7. Which are the filters used to create artistic effects in the image?

8. Which are the filters used to blur images in a variety of ways?

9. ‘Emboss’ filter is available in which menu item?

10. Explain different colour schemes.

11. Explain any three Blur Filters.

12. Explain any three Artistic Filters.

13. Explain any three Distorts Filters.

14. Explain the use of Paths tool.

15.  Explain various categories of filters available in GIMP.
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CHAPTER 8

Computer Networks

Computer Networks: It is an interconnection of computers and other hardware devices like printers, 
scanners, etc using a communication medium.

Advantages 

1) Resource sharing -  Any hardware /software resource in one system can be shared with 
other systems in the network.

2) Price-performance ratio - The cost of 
purchasing licensed software for each 
computer, can be reduced by purchasing 
network versions of such software in a 
network.

3) Communication – The computer network 
helps users to communicate with any other 
computer in the network through its services 
like e-mail, chatting, video conferencing, etc.  Fig 8.1 Computer Networks

4) Reliability- In a network, it is possible to backup data on multiple computers. This helps 
users to retrieve data in the case of failures in accessing data.

5) Scalability - Computing capacity can be increased or decreased easily by adding or 
removing computers to the network.

Some key terms

Bandwidth : It measures the amount of data that can be sent over a specific connection in a given 
amount of time.

Noise: It is unwanted electric or electromagnetic energy that lowers the quantity of data signals.

Node: Any device which is directly connected to a network is called a Node.

Data communication devices:

A data communication device provides an interface between computer and the communication 
channel.

1) Switch:

➢ A switch is a device that connects 
several computers to form a network.

➢ It an intelligent device,  because it can 
transmit the received data to the 
destination only.

➢ It will store the addresses of all the 
devices connected to it . Fig 8.2 Switch
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2) Bridge

 A bridge is a device used to 
segmentize a network.

 A network can be split into 
different segments and can be 
interconnected using a bridge.

 This reduces the amount of traffic 
on a network.

Fig 8.3 Bridge

3) Router

 A router is a device that can 
interconnect two networks of the same 
type using the same protocol.

 It can find the optimal path for data 
packets to travel and reduce the amount
of traffic on a network. Fig 8.4 Router

4) Gateway : 

 A gateway is a device that can 
interconnect two different networks 
having different protocols.

 It can translate one protocol to another. 

 It can find the optimal path for packets 
to reach the destination. Fig 8.5 Gateway

Data Terminal Equipments: 

Data terminal equipment is a device that controls data flowing to or from a computer.

1) Modem : 

 A modem is a device used for 
communication between computers 
through telephone lines.

 The name is formed from  modulator 
and demodulator.

 It converts digital signals received from
a computer to analog signals for 
telephone lines and vice versa.

Fig 8.6  Modem

Network topologies 

Topology : The way in which the nodes are physically interconnected to form a network. 

Major topologies are bus, star, ring, and mesh.
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1)Bus topology: 

 In bus topology, all the nodes are 
connected to a main cable called bus.

 A small device called a terminator is 
attached to each end of the bus.

Fig 8.7 Bus topology

 If a node has to send data to another node, it sends data to the bus. The signal travels 
through the bus and each node checks the bus and only the intended node will accept the
data. When the signal reaches the end of the bus, the terminator absorbs the signal from 
the bus.

Characteristics of bus topology

1)Easy to install.

2)Requires less cable length and hence it is cost-effective.

3)Failure of a node does not affect the network.

4)Failure of cable (bus) or terminator leads to a breakdown of the entire network.

5)Fault diagnosis is difficult.

6)Only one node can transmit data at a time.

2)Star topology

 In star topology, each node is directly 
connected to a hub/switch.

 If any node has to send some 
information to any other node, it sends 
the signal to the hub/switch. 

 The signal is then broadcasted (in the 
case of a hub) to all the nodes but is 
accepted only by the intended node.

 In the case of a switch, the signal is sent
only to the intended node.. 

Fig 8.8 Star topology

Characteristics of star topology 

1)More efficient compared to bus topology.

2) Easy to install.

3) Easy to diagnose faults. 

4)Easy to expand depending on the specifications of the central hub/switch. 

5)Failure of hub/switch leads to failure of the entire network. 

6) Requires more cable length compared to bus topology.

Vijayabheri, District Panchayath Malappuram 29  



3) Ring topology

 In ring topology, all nodes are connected using a 
cable that loops the ring or circle. 

 A ring topology is in the form of a circle.

 Data travels only in one direction in a ring. 

 Each node regenerates the signal and passes to 
the next node until it reaches the intended node 
reaches. Fig 8.9 Ring topology

Characteristics of ring topology

1) No signal amplification is required as each node amplifies the signal.

2)Requires less cable length and hence is cost-effective.

3)If one node fails, the entire network will fail.

4) Addition of nodes to the network is difficult.

4) Mesh topology :

 In mesh topology, every node is connected to 
other nodes.

 There will be more than one path between two 
nodes.

 If one path fails, the data will take another path 
and reach the destination.

Characteristics of mesh topology

1) Network will not fail even if one path 
between the nodes fails.

2) Expensive because of the extra cables needed.

3)Very complex and difficult to manage.

Fig 8.10 Mesh topology

Types of networks

On the basis of the area covered, computer networks are classified as: 

• PAN - Personal Area Network

• LAN - Local Area Network 

• MAN - Metropolitan Area Network

• WAN -Wide Area Network
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1) Personal Area Network (PAN)

 PAN is a network of communicating devices 
(computer, mobile, tablet, printer, etc.) in the 
proximity of an individual.

 It can cover an area of a radius of few meters.

Fig 8.11 PAN

2) Local Area Network(LAN)

 LAN is a network of computing and 

 communicating devices in a room building or 
campus.

 It can cover an area of few meters to few 
kilometers.

Fig 8.12 LAN

3) Metropolitan Area Network(MAN)

 MAN is a network of computing and 
communication devices within a city.

 It can cover an area of a few kilometers to a 
few hundred kilometers radius.

 MAN is usually formed by interconnecting a 
number of LANs and individual computers.

Fig 8.13 MAN

4) Wide Area Network(WAN) 

 WAN is a network of computing and 
communicating devices crossing the limits of 
a city, country, or continent.

 It can cover an area of hundreds of Kilometers
in radius.

Fig 8.14 WAN
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Summary of PAN, LAN, MAN, WAN

Parameter PAN LAN MAN WAN

Area covered
Small area (Up 
to 10 m radius)

A few meters to 
few Kilometers 
(Up to 10 Km 
radius)

A city and its 
vicinity (Up to 
100 Km radius)

Entire country, 
continent, or 
globe

Transmission
speed

High speed High speed Moderate speed Low speed

Networking
cost

Negligible Inexpensive
Moderately 
expensive

Expensive

Identification of Computers on a network 

1) Media Access Control (MAC) address:

 A universally unique address (12 digit hexadecimal number) assigned to each NIC (Network 
Interface Card) by its manufacturer.

 MAC addresses are usually written in one of the following two formats:

 MM : MM : MM : SS : SS : SS or MM – MM – MM – SS – SS – SS

 The first half (MM:MM:MM) of a MAC address contains the ID number of the adapter 
manufacturer. 

 The second half (SS:SS:SS) of a MAC address represents the serial number assigned to the 
adapter (NIC) by its manufacturer.

eg. 00:A0:C9 : 14:C8:35

2) IP address:

 An IP address is a unique 4 part numeric address assigned to each node on a network, for their 
unique identification. 

 An IP address is a group of four bytes (or 32 bits) each of which can be a number from 0 to 
255.

Fig 8.15 IP address
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Sample Questions

1. A----------- is a computer peripheral that allows you to connect and communicate with other 
computers via telephone lines.

2. In ----------topology, all devices are connected to a central hub/switch.

3. Explain any two advantages of computer networks.

4. There are many advantages in using networked computers instead of stand-alone computers.      
Write any four advantages of them.

5. Differentiate between HUB and SWITCH.

6. Define the term, topology. Consider that, your principal has decided to network your computer 
Iab. Which topology will you suggest? Justify your answer.

7. Compare ring topology and mesh topology.

8. Define following terms related to computer network

a) Bandwidth b) Noise c) Node

9. How is a WAN different from a LAN ?
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CHAPTER 9

Internet

Services on Internet

The internet offers a variety of services like WWW, e-mail, search engines, social media.

1) World Wide Web (WWW) : WWW is a huge client-server system consisting of millions of 
clients and servers connected together.

a) Browser : 

 A web browser is a software that we use to 
retrieve or present information and to 
navigate through web pages in the World 
Wide Web.

 Some common browsers are Google 
Chrome, Internet Explorer, Mozilla Firefox,
Opera, and Safari.

b) Web browsing:

 Traversing through the web pages of World 
Wide Web is called web browsing.

Fig 9.1 WWW

2) Search engines

 Internet search engine websites are special 
programs that are designed to help people 
to find the information available in World 
Wide Web. 

 Search engine programs search documents 
available on the World Wide Web for 
specified keywords.

 It returns a list of the documents/web pages
matching the keywords.

 Some of the most popular web search 
engine sites are Google, Bing, Yahoo 
Search, Ask, etc.

Fig 9.2 Search engine
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3) E-Mail : Electronic mail or e-mail is a 
method of exchanging digital messages 
between computers over Internet. 

Sections of an e-mail

To  (Recipient Address), Cc (Carbon copy), 
Bcc (Blind carbon copy), Subject, Content 

Advantages of using e-mail

Speed, Easy to use, Provision of    attachments,
Environment friendly, Reply to an e-mail, 
Cost-effective, Available anywhere anytime

Disadvantages of using e-mail

E-mails may carry viruses, Junk mails
Fig 9.3 Email

4) Social media :

Social media refers to the use of mobile and 
web-based technologies through which 
individuals and communities can create, share, 
discuss and modify content.

Classification of social media.

a) Internet forums – It is an online discussion 
website where people can engage in 
conversations in the form of posted messages.

e.g.  Ubuntu Forum.
Fig 9.4 Social Media

b) Social blogs – It  is a discussion or informational website consisting of entries or posts 
displayed.e.g. Blogger and WordPress

c) Microblogs -Microblogs allow users to exchange short sentences, individual images or video 
links. e.g. Twitter.com

d) Wikis -Wikis allow people to add content or edit existing information in a web page, to form 
a community document.e.g.wikipedia.org

e) Social networks -Social networking sites allow people to build personal web pages and then 
connect with friends to communicate and share content. e.g. facebook.com and LinkedIn.

f) Content communities -Content communities are websites that organise and share contents 
like photos, videos, etc. e.g. YouTube

Vijayabheri, District Panchayath Malappuram 35  



Advantages of social media 

➢ Bring people together, 

➢ Plan and organise events

➢ Business promotion

➢ Social skills

Limitations in use of social media

➢ Intrusion to privacy

➢ Addiction

➢ Spread rumours

Cyber Security

Computer Virus

 Its a program that attaches itself with another program or file to spread from one computer to 
another without our knowledge

 It will affect our normal operation of the computer

 It can corrupt or delete our files

Trojan Horse

 It will appear to be  useful software but it can damage our files once installed or run in the 
computer

 Some Trojan creates a backdoor on the computer

 This gives malicious users access to confidential or personal information in the computer through 
the network

Hacking

 It is the unauthorized access of a computer, files or network

 The person who is doing this is called hacker 

 Hacking is performed both by computer security experts and by computer criminals

 Computer experts perform hacking to test the security of the network

 Such computer experts are called “white hats” and this type of hacking is called “ethical hacking

 Computer criminals breake into a network and destroy data and Such criminals are called ‘black 
hats’

 Gray hat hackers are fall between white and black hackers

 They act as both white hats and black hats

Phishing

 Phishing is an attempt to acquire information such as username, passwords, credit card details by 
acting like the original websites of the banks and other financial institutions.The process of making
these misleading websites is called spoofing
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Sample Questions

1. Internet offers a variety of services and they are used widely around the world.

a) One of these services requires an address like journey23@gmail.com. Name this service 
and write the reasons for the wide use of this service.   

b) Name the service which provides a list of websites containing information about a word 
or a phrase

2. Define the terms :

(a) Phishing

(b) Hacking

3. Write any two drawbacks in using social media.
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CHAPTER 10

IT Applications

e-Governance

 Government uses internet and communication technology for delivering their services for the 
people

Types of interactions in e-Governance

1) Government to Government (G2G)

 It is the sharing of data or information between government department or  organisations           

2) Government to Citizens (G2C)

➢ It creates an interface between the government and citizens. Here the citizens enjoy a large range of
public services

3) Government to Business (G2B)

➢ The business people can interact with the government by using ICT tools

4) Government to Employee (G2E)

➢ Government uses information and communication tools for the interaction with their employees

e-Governance Infrastructure

1. State Data Centre (SDC)

 Responsible for delivering online services for the citizens, keeping the central database of 
the state, securing data storage.

2. Kerala State Wide Area Network (KSWAN)

 It acts as a backbone of the e-Governance infrastructure 

 It connects Thiruvananthapuram, Kochi, and Kozhikode as its hubs and extends to all the 
14 districts linking each of the 152 Block Panchayaths.

3. Common Service Centres (CSC)

➢ It is the front end delivery point of the e-Governance services for the rural areas.

➢ It helps in utility payments such as electricity, telephone and water bills, submission of 
online applications etc.

➢ Eg: Akshaya Centres

e-Business

➢ It is the sharing of business information, maintaining business relationships and conducting 
business transactions with the help of information technology

1. e-Commerce and e-Business

 e-Commerce covers business transaction that involves exchange of money
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 e-Business includes all aspects of running a business such as marketing, obtaining raw 
materials or goods, customer education, looking for suppliers, etc.

2. Electronic Payment System (EPS)

 A system of financial exchange between buyers and sellers in an online environment is 
called EPS

 The financial exchange is done by credit/debit card, electronic cheque or digital cash

3. e-Banking

➢ it is the automated delivery of banking services directly to customers through electronic 
channels.

Advantage of e-Business

 It overcomes geographical limitation

 Reduces the operational cost

 It minimises travel time and cost

 It remains open all the time

 We can locate the product quicker from the wider range of choice

Challenges to e-Business

 Lack of knowledge about e-Business and its possibilities

 Rural population do not possess plastic money- credit card, debit card and net banking 
system

 If not used with caution, customers may lose valuable information like their credit card 
number, passwords, etc.

 Customers don't have this ‘touch and feel’ advantage

 Efficient shipment facility is needed 

e-Learning

 The use of electronic media and IT in education is termed e-Learning.

e-Learning Tools

1. Electronics Book Reader (e-Books)

 Portable computer devices that are loaded with digital book content via communication 
interfaces is called electronic books reader

2. e- Text

 Textual information available in electronic format is called e-Text

3. Online Chat

 It is a real-time exchange of text messages between two or more persons over the internet.
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4. e-Content

 The e-Learning materials such as videos, presentations, animations, graphics etc. are called 
e-Content

5. Educational TV channels

 These television channels are dedicated for e-Leaning purpose

 These channels broadcast recorded classes on various subjects, interviews with experts, lab 
experiments etc.

Advantages of e-Learning

 It can offer courses on a variety of subjects to large number of students from a distant 
location.

 Cost for learning is much less

 Students can do online courses from various nationally or internationally reputed 
institutions.

 Time and place is not a constraint for e-Learning.

Challenges to e-Learning

 Face to face contact between students and teachers is not possible.

 Limited interaction between teachers and students

 Computers or any similar kind of devices and high speed internet is required for e-Leaning

 Students will not get any individual attention

 Hands-on practicals in real laboratory scenario is also a constraint in e-Learning.

Sample Questions

1. Write any two challenges for implementing e-Governance.

2. e-Learning allows us to overcome many limitations of conventional teaching-learning process.

a) Name any three e-Learning tools for enhancing e-Learning process. 

b) Write any three advantages of e-Learning. 

3. Compare the advantage and disadvantages of implementing e-Business.

4. Almost all services and business are available online now.

a) Name the system that facilitates money transaction between buyers and sellers in such 
cases.

b) Explain the infrastructure of e-Governance.

5. Briefly describe any two benefits of e-Governance.
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