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Computer Application (H) II – Notes 

 

1. INTRODUCTION TO PUBLISHING 

Publishing- Creation, compilation and mass 

reproduction of text and graphics.  

Stages in publishing 

I Prepress- stages before printing. From design to 

printing. DTP used 

A. Designing- the layout preparation  

Elements of Design: -  

Line - convey moods 

Shape- add interests  

Colors- create mood 

Space- three dimensional volumes 

Typography- art of arranging letters 

(two- sans serief-without feet serief- with feet) 

Principles of design: - 

Balance - distribution of visual weight  

Repetition - a pattern to make the art active  

Contrast - association of opposite elements  

Harmony - relates and complement each other  

Unity - visual linking of elements  

Dominance - giving emphasis 

B. Pre-flighting - checking of files for completion  

Crop marks- marks of trimming the paper  

Bleed - area to be trimmed 

Margin - area between content and edge 

C. Creating proof- the state of finished product. 

D. Printing plates- used in offset press.  

II Printing 

Process/ Types 

Lithographic- repulsion of oil and water- offset/plate 

Digital- no plates, inkjet or laser printing 

Gravure- nylone, polyester, laminated package printing 

Flexography- for printing on packing material 

Screen printing- use woven mesh and ink blocking 

stencil 

III Post Press 

Folding- folding of paper to get pages in correct order 

Assembling- arranging of pages in correct order 

Binding- physical assembling 

Cutting- cutting of page ends after binding  

Electronic Publishing 

Digital publication of e-books, magazines etc. 

Web based -publishing the content on the internet 

Digital distribution-downloadable publishing 

 

 

2. INTRODUCTION TO WORD PROCESSOR 

Features of word processor 

Quickness- helps easy creation 

Word wrapping- to next line at margin automatically 

Editing features- easy correction and editing  

Drawing and graphics- tools for drawing 

Tables- data in rows and columns 

Formatting feature- like character, paragraph, page 

Header, Footer and Page number- 

OLE- object linking and embedding  

Spell check and grammar checking- 

Mail merging- mails with same content and different 

address  

Index and table of content- 

Templates- predefined document formats 

Libre Office writer IDE 

Title bar- name of document and software at top  

Menu bar- file, edit, insert, view etc. 

Tool bar- buttons for commands 

Scroll bar- to move up and down, left and right  

Ruler- to change margins 

Status bar- information of cursor position- at bottom  

Text area- to type text matter 

To create new document 

File->New-> text document or Ctrl+N or New button  

Saving a document 

File-> Save or Ctrl+S or F2 

Opening a document 

File->open, Ctrl+O 

Closing a document 
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File->Close or Close button in menu bar 

Closing software- 

File->Exit LibreOffice or Ctrl+Q, close button in title 

bar  

Prerequisite for editing 

A. Navigation -moving one point to another 

arrow keys-move to very next character home- to 

beginning of the current line End- to the end of the 

current line 

page up- cursor one page up 

page down- cursor one page down 

Ctrl+-> to beginning of the previous word  

Ctrl+<- to beginning of the next word  

Ctrl+home to beginning of document  

Ctrl+End to the end of the document 

B. Insert/overwrite mode 

insert- insertion without losing existing  

overwrite- insertion with replacing 

C. Undo/redo 

undo- cancelling most recent action 

redo- retrieving action cancelled by undo 

D. Text Selection 

using mouse using key board 

Cut, Copy, Paste functions (Clipboard – temporary memory) 

Cut- moving a text. Edit->Cut or Ctrl+X or Cut button 

Copy- copy from one place to another. Edit->Copy or 

Ctrl+C or Copy button 

Paste- Edit->Paste or Ctrl+V or Paste button 

Find and Replace facility (Edit-> Find and Replace) 

Find- Ctrl+F 

Replace- Ctrl+H 

Formatting- General arrangements of text 

I. Character formatting (format->character)-  

Tabs in the dialog box  

 Font- family, style (Bold, Italic, Underline), size 

 Font effects- font color, effects (capital, small), 

relief, over lining, strikethrough, underlining, out 

line, shadow. 

 Position- superscripting, subscripting, rotate, 

spacing hyperlink, background, borders 

Copying format 

 Select the text-> click format paintbrush button-

>click where we want  

II. Paragraph formatting (Format-> paragraph) 

Paragraph alignment-  

 Horizontal:-left, right, centered, justified 

 Vertical:- top, bottom, middle  

Indentation- distance between text boundaries and 

page margin 

Positive indent- inward from margin - before text  

Right indent- outward from margin - after text  

First line indent- only first line inward from margin 

Hanging indent- other than first line inward from 

margin 

Line spacing- space between two lines 

Drop caps- First letter in height of two or more lines 

paragraph->drop caps 

Bullet and numbering (edit-> bullet and numbering) 

  Bullet list, Numbered list 

III. Page formatting-setting of page layout  

 (Format->Page) 

Page orientation- Portrait- lengthwise 

 Landscape- width-wise 

Margin setting-using ruler bars and using page style 

dialog box  

Header and Footer-insert->header, insert->footer 

Printing- Ctrl+P or  File->print 

Print preview- File->print preview or Ctrl+Shift+O 

 

3. CREATING PROFESSIONAL DOCUMENTS 

Inserting Tables-3 ways 

Standard Toolbar or Table->Insert->Table or Ctrl+F12 

Border to table- Table->Table Properties 

Table->auto fit- makes equal width to selected columns 

 Inserting new row- Table->Insert->Rows 

Inserting new column- Table->Insert->Columns 

Deleting- Table->Delete-Rows  

Merging rows/columns- Table->Merge cells  
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Splitting rows/columns- Table->Split cells  

Inserting Graphics(3 Types) 

Adding an image- Insert->Image->From file, Select 

the image 

Drawing tools- View->Toolbars->Drawing 3D effect 

for an object- Extrusion on/off 

Inserting Charts- Insert->Object->Chart->chart 

wizard, select the chart type, finish  

Inserting Special Character- Insert->Special 

Character 

Inserting Page Breaks- Insert->Manual break. Select 

page break .OK(Ctrl+Enter)  

Inserting Page Border- Format->Page->Border tab-

>select style  

Exporting to pdf & inserting water marks- File-

>Export as PDF->type water mark->export  

Converting Text to Table- Table->convert text to 

table. Select separator. OK  

Splitting text into columns-Format->Columns. No of 

columns. OK  

Spelling Grammar (two ways) 

1 Auto spell check button 

2 tools->spelling and grammar 

Auto correct-correcting common misspell words  

Inserting Formulas- Insert->Object->Formula  

Table of Content (two steps) 

1 Creating TOC entry select the heading 

Insert->Index and Tables-> Entry set index as table 

of contents insert 

2 Creating table of contents, click on fresh page 

Insert->index and tables-> index and tables table of 

content in type box, click OK 

Defining Index Entries (three steps) 

1 Decide the words 

2 Creating Index Entries-Click on a word.  

 Insert->index and tables->entry 

3 Creating Index Page 

Insert->Index and Tables->index and tables select 

alphabetical index in type box 

Templates- Document models 

File->New->Template 

Creating template- create a document.  

File->Template->Save as templates 

Mail merge- to send a letter to many addressee select 

Starting document 

Select document type  

Insert address book  

Create salutation  

Adjust layout 

Edit document  

Personalise 

Save, Print or Send 

 

Chapter 4 – WEB TECHNOLOGY 

Communication on Web: 
1. Client to Web Server 
2. Web Server to Web Server 

DNS – Domain Name System 
TCP/ IP – Transmission Control Protocol/ Internet 
Protocol 
Web Server Technologies: 

1. Web Server: It always switched ON and 
connected to a high bandwidth internet 
connection 

2. Software Ports: Hardware ports that connect 
external devices to the computer 

3. DNS Server: It runs special purpose networking 
software 

 
 

 

Scripts: Program code written inside HTML Page 
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Types of scripting languages: 

 

Basic Structure of HTML document: 

<HTML> 
<HEAD> 

<TITLE></TITLE> 
 

</HEAD> 
<BODY> 
 
</BODY> 

</HTML> 

Container Tag:  Tags used in pair (both Start tag and 

End tag (forward slah – ‘/’)). Eg: <HTML>, <BODY> 

Empty Tag:  Only start tag.  No End tag.  Eg: <BR>, 

<INPUT> 

 
Essential HTML tags: Refer Page No. 105 to 129 

 

S.No Tag Description Attributes Values 

1. <HTML> 
Essential tag for HTML 
document 

Dir, Lang  

2. <HEAD> 
Head of an HTML 
document 

  

3. <TITLE> 
Title of an HTML 
document 

  

4. <BODY> Specifies document body 

Background 
BGColor 
Text 
Link, ALink, VLink 
Leftmargin, Topmargin 

Sets an Image 
Sets background color 
Sets text color 
Sets text color 
Sets margin size 

5. <H1> to <H6> Heading Tags Align Left, Right, Center 

6. <P> Paragraph 
Align Left, Right, Center, 

Justify 

7. <BR> 
Insert Line break – New 
line 

  

8. <HR> Draw horizontal line 
Size (thickness), Width 
(length), NoShade, 
Color 

 

9. <CENTER> Centering the Content   
10. <B> Making text Bold   
11. <I> Making text Italics   
12. <U> Making text Underline   

13. <S>, <STRIKE> 
Making text Striking 
through 

  

14. <BIG> Making text BIG sized   
15. <SMALL> Making text SMALL sized   
16. <STRONG> Making text Bold   
17. <EM> Emphasizing the Text   
18. <SUB> Sub Script   
19. <SUP> Super Script   

20. 
<Q>, 

<BLOCKQUOTE> 
Indenting a quotation 

  

21. <PRE> Pre formatted Text    
22. <ADDRESS> Display the Address   
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23. <MARQUEE> Scrolling the text 

Height, Width, 
Direction 
Behaviour, ScrollDelay, 
ScrollAmount, Loop, 
BGColor, HSpace, 
VSpace 

 

24. <DIV> Formatting a block of text Align, ID, Style  

25. <FONT> To set Font 
Color, Face (font name), 
Size 

 

26. <!--   --> Comment   

27. <IMG> Insert Image 

SRC 
Width, Height,  
VSpace, HSpace,  
Align, Border, 
Alt 

Specify Source file 
name 
 
 
 
Display alternative text 

 

 
Chapter 5 – Web Designing using HTML 

S.No Item  Tag Description Attributes Values 
1. 

Lists 

<UL>, <LI> Unordered List Type Disc, Square, Circle 

2. <OL>, <LI> Ordered List 
Type 
Start 

1, A, a, I, i 
Starting number 

3. 
<DL>, <DT>, 

<DD> 
Definition List 

  

4. 
Links – 
Anchor 

Tag 
<A> To set Hyperlink 

HRef 
Name 

Specify Webpage location 
(URL) 
Name for internal link 

5. 

Insert 
Music and 

Video 
<EMBED> 

To Insert Music or 
Video 

SRC 
Height, Width 
Align, Alt 
Hidden 

Specify Source file name 
 
 
True, False 

6. 

Table 

<TABLE> To draw table 

Border, 
Bordercolor, 
Align,  
Background, 
BGColor,  
CellSpacing, 
CellPadding, 
Width, Heigh, 
Frame 
Rules 

 
 
 
URL of background 
Image 
 
Space between cells 
Space between content 
and border 
 
Void, Above, Below,Box 
Cols, rows, groups, all 

7. <TR> Table Row  
Align 
VAlign 
BGColor 

Left, Right, Center 
Top, Middle, Bottom, 
BaseLine 

8. <TH>, <TD> 
Table Head, 
Description 

Align 
VAlign 
BGColor 
ColSpan 
RowSpan 

Left, Right, Center 
Top, Middle, Bottom, 
BaseLine 
 
Join Columns 
Join Rows 

9. <CAPTION> To set Table Heading   

10. Frame <FRAMESET> To set Frames 
Cols 
Rows 
Border 

Specify number of 
Columns 
Specify number of Rows 
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BorderColor  

11. <FRAME> To set Frame contents 

SRC 
Scrolling 
NoResize 
Marginwidth 
MarginHeight 
Name 
Target 

Specify URL to display 
 

12. <NOFRAME> 
If browser not 
supporting Frames 

  

13. 

Forms 

<FORM> For Creating Forms 

Action 
Method 
Target 

Specify File handler 
URL 
GET, POST 
_blank, _self, _parent 

14. <INPUT> 
To create form 
controls 

Type 
 
Name, Value 
Size, 
MaxLength 

Text, Password, 
CheckBox, Radio, Reset, 
Submit, button 
 

15. <TEXTAREA> 
To enter Multiline 
text 

Name 
Rows, Cols 

 

16. 
<SELECT> 

 
<OPTION> 

To Set combo box 
and options 

Name, Size, 
Multiple 
Selected, value 

 

17. 
 

<FIELDSET> 
<LEGEND> 

Grouping form data 
To set title for 
<FIELDSET> 

  

 
 

 
  

  

 

 

6. CASCADING STYLE SHEET 

Advantage of using CSS  

Easy to change layout  

Reduce the size bandwidth  

Reduction consistency 

Viewing options  

Save time 

Style rule – how to display a particular elements (two parts)  

 

 

 

 

Selector- CSS applying HTML tag 

Declaration- property names and values  

eg:- p{margin:40px;} 

Selectors (4 types) 

Universal selector(*)- applicable to all elements 

*symbol and declaration 

*{margin:40px;} 

Type selector- style to an element 

Element and declaration p{margin:40px;} 

Class selector(dot)- style to the desired element 

.mystyle{mrgin:40px;} 

ID selector(#) -style to single element 

#mystyle{mrgin:40px;}  

Properties in CSS- key word used in style rules 

Font properties: font-family, font-style, font-weight, 

font-size 

Text properties: text-align, text-decoration, text-indent, 

line-height 

Ways to add CSS in a webpage 

Internal- between <STYLE> and </STYLE> 

External- separate CSS file linking using <LINK> tag 

Inline style- in a tag. 
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7. WEB HOSTING 

Web hosting- giving storage space in web server web 

Hosts- companies of web hosting 

Types of web hosting 

Shared- Many websites sharing single web server, 

RAM and  CPU. Cheaper, Easy to use, Slow. 

Dedicated- A web server for a website, Good 

performance, Expensive, Co-location- placing 

dedicated web server in service providers facility  

Virtual private Server- a shared web server which feels 

dedicated virtually 

Buying hosting space- 

 Consider- Memory space, Supporting soft wares, 

Database support  

Domain name registration 

Decide a domain name,  

Ccheck for availability in WHOIS database  

Fill information for WHOIS database  

WHOIS information: Name, Address, Phone no.,Email, 

etc, Pay the annual fee 

ICANN- Internet Corporation for Assigned Names and 

Numbers  

A record- IP address of a web server connected to a 

domain name  

FTP- Client- software to transfer file to web server 

SFTP -Secure shell FTP 

Free hosting- Hosting without charge 

Eg- site.google.com, yola.com 

CMS- Content Management System: Software used 

to create, admin and publish websites  

Features: Security, Need less technical knowledge, 

Templates, Reduce repeat coding, Economical 

Responsive web design 

Designing web pages able to adjust to the screen size 

of the device using 

 Flexible grid layout- set entire page size 

 Flexible images- set image/video dimensions  

 Media queries- set different styles 

 

8. DATA BASE MANAGEMENT SYSTEM 

Draw backs of conventional file management system  

Duplication of data 

Data inconsistency in accuracy 

Less security 

Not sure of data consistency if system crash  

No standard 

Database- Organized collection of interrelated data  

DBMS- programs for managing database  

Advantages of DBMS 

Controlling data redundancy- centralized databases 

 Data consistency- by controlling data redundancy  

 Efficient data access- 

 Data integrity- by standard rules and error checking  

 Data security- 

Sharing- 

Standard enforcement  

Crash recovery- 

Components of DBMS 

Hardware- computers and supporting devices  

Software- DBMS, application programs and utilities 

Data- operational data and Meta data (Data about data) 

Field- smallest unit  

Record- collection of fields 

File- collection of records 

 Users- users of database 

 Procedure- instruction and rules related to database 

Data abstraction- Hiding of complexity from users 

 Physical- how data is stored  

 Logical- what data is stored 

 View level- the way in which user view the data 

Data independence- modification data structure in one 

level without affecting higher level 

 Physical- modifying physical level without affecting 

logical level 

 Logical- modifying logical level without affecting 

view level  
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Users of database 

Database Administrator (DBA)- who control the 

database  

 Duties- Design of structure, Security, Data availability 

Application programmer- who connect database 

through programs  

Sophisticated user- who know about DBMS well 

Naive user- common users 

Relation Data Model- collection of tables  

Entity-  a person or a thing  

Relation- data in tabular form  

Tuple- the row 

Attribute- column 

Degree- No of attributes or columns  

Cardinality- no of rows 

Domain- pool of values of a column 

 Schema- structure of databases 

 Instance- is group of rows in a relation 

Keys- way to identify a row in a relation uniquely  

Composite key- having more than one column 

 Candidate key- column or columns that can be a key 

Primary key- chosen key for a table from 

candidate keys  

Alternate key- candidate key that is not primary key 

Foreign key- a key in a table that is a primary key 

in another table  

Relational algebra 

Select (σ) - select rows on a condition 

Project (π) - select columns 

Union (U) - all tuples in either or both of the two 

relation  

Intersection (∩) - all tuples in both of two relation 

Set difference (-) - tupels in first and not in second 

Cartesian product (X) - all possible combination of 

tuples 

 

 

9. STRUCTURED QUERY LANGUAGE 

SQL- standard database language 

Features- 

Database language, Simple, flexible, Powerful, 

Command for table modification and data usage, 

Databases uses for operation, Non procedural 

language, Data security, Concept of views 

Components of SQL 

DDL- data definition language( defining structure) 

 CREATE, ALTER, DROP 

DML- Data manipulation Language 

SELECT, INSERT, UPDATE ,etc. 

DCL- Data control language  

 GRANT, REVOKE 

Creating database-  

 CREATE DATABASE <databasename>;  

Opening database-  

 USE <databasename>; 

Data types- 

 Numeric- INT, DEC 

String- CHAR- use of declared size,   

VARCHAR- use of actual size 

DATE (yyyy/mm/dd), TIME 

Rules for naming tables- 

 Contain letters, digit, under score 

One character must 

Not contain white space, symbols  

No keywords 

No duplicate  

Constraints- rules on entering data in a column 

 Column constraints- constrains on single columns  

 NOT NULL- never empty 

AUTO-INCREMENT- 

 UNIQUE - no two rows have same values  

PRIMARY KEY 

 DEFAULT setting default values  

Table constraints: Constraints on group of columns 

Structure view of a table- DESC <tablename>; 

Inserting data- INSERT INTO.. 

Retrieving - SELECT ...FROM 

Eliminating duplicate- SELECT DISTINCT 
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Condition WHERE 

Pattern matching LIKE %, LIKE ' __ 

Sorting ORDER BY 

Aggregate functions 

SUM()- total of column values  

AVG()- average of column values 

MIN()- smallest in the column 

MAX()- Largest value 

COUNT()- number of non null values 

COUNT(*)- number of row 

Grouping of records- GROUP BY 

 HAVING- condition in GROUP BY 

Modifying data- UPDATE SET 

Changing table - ALTER TABLE 

ADD(after, first),  MODIFY, DROP, RENAME TO 

Deleting rows- DELETE FROM... 

Remove table- DROP TABLE... 

VIEW- virtual table 

CREATE VIEW       AS SELECT 

 

 

10. TRENDS AND ISSUES IN ICT 

Mobile computing- computing and net use in motion  

Generation in mobile computing 

IG- in 1980. Analog. Voice only 

2G- Digital. Data service. MMS. Use GSM and CDMA. 

 GSM-global standard circuit switched network 

 GPRS- general packet radio service 

 EDGE- Enhanced data rates for GSM evolution  

 CDMA- Code Division Multiple Access- several 

signals at a time 

3G- voice and data. Wireless broadband. WCDMA 

4G- Long Term Evolution. ultra broadband. OFDMA. 

quality than TV  

5G- next step. More connection. Less cost. Less energy. 

Mobile Communication Services 

SMS- Text messages. SS7 protocol is used  
MMS- Multimedia message. 

 GPS- Finding global position using satellite.  
 Smart cards- Plastic cards with computer chip. 
 

Mobile operating system 

 Android- linux based. Maintained by OHA. Touch 
input. Software development kit. Appache license. 
Apps. 

Information Security: 

Intellectual Property Right (IPR) 

1. Industrial Property 

a. Patents 
b. Trademark 
c. Industrial Design 

2. Copyright 

Infringement: Unauthorized use of IPR 

a. Patents b. Trademark 
c. Industrial Design d. Copyright 

Cyber Space: It is a virtual/ simulated environment 
connected to Internet 

Cyber Crime: Criminal activity by the help of Internet.  
It is against Individual, Property and 
Government. 

A. Individual 

a. Identity Theft 
b. Harassment 
c. Impersonation and Cheating 
d. Violation of Privacy 
e. Dissemination of obscene material 

B. Property 

a. Credit card fraud 
b. Intellectual property theft 
c. Internet time theft 

C. Government 

a. Cyber terrorism 
b. Website defacement 
c. Attacks against e-Governance websites 

Cyber Ethics: Cyberspace do not harm others 

1. Use Antivirus, Firewall 
2. Ensure Security of Websites 
3. Do not respond unknown sources 
4. Use unique and complex passwords 
5. Avoid unauthorized software 
6. Do not hide your identity 
7. Do not use bad or rude language 

Cyber Law: Legal and regulatory aspects of the 
Internet 

1. IT Act 2000 
2. Amended on 2008 

Cyber Forensics: Combine element of law and 
computer science  
Info mania: Excessive enthusiasm for acquiring 
knowledge 
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